Jump to content
Cruise Critic Community
abbydancer

Lost access to the website

Recommended Posts

So, I haven't logged into my account on the Celebrity for quite a while.  A couple of weeks ago, I wanted to check my points, so I tried.  Here's what happened.

 

 
When I try to get logged in, I get a message that "We've got your info.  However we're unable to bring up your account right now, so please try again later".
 
So, I changed my password.  
 
When I click go to my account from the password notification email I get the website on vacation message.  
 
I've changed it 5-6 times.  Nothing has changed.
 
Who do I contact about this?
 
Thanks for any help.
 

Share this post


Link to post
Share on other sites

I got the same message today using Google Chrome.  Switched to Explorer and got into my account with no issues.  

Share this post


Link to post
Share on other sites

I've had this happen a number of times over the past couple weeks.   I found that if I close the browser and/or try a different browser it works perfectly.   On a couple occasions I found a browser open in background when I checked  Task Manager.    Killing the process also fixed the problem.    I had it happen today myself   

 

If it is truly credentials I don't think you would get that message but you could call Captains Club.

Share this post


Link to post
Share on other sites
1 hour ago, abbydancer said:

So, I haven't logged into my account on the Celebrity for quite a while.  A couple of weeks ago, I wanted to check my points, so I tried.  Here's what happened.

 

 
When I try to get logged in, I get a message that "We've got your info.  However we're unable to bring up your account right now, so please try again later".
 
So, I changed my password.  
 
When I click go to my account from the password notification email I get the website on vacation message.  
 
I've changed it 5-6 times.  Nothing has changed.
 
Who do I contact about this?
 
Thanks for any help.
 

 

If its been quite awhile since you logged in be advised that sometime last year Celebrity required that all IDs be an Email address.   If you haven't try putting your ID in with an email ending. 

Share this post


Link to post
Share on other sites
1 hour ago, abbydancer said:

Thanks all.  Works in Firefox.

 

 

Good to hear.   Firefox is my default browser but have had the problem in Firefox also.  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Forum Jump
    • Categories
      • SAIL-AWAY GIVEAWAY - Enter Now for a Chance to Win a 7-day Cruise for Two
      • Q&A with InsureMyTrip
      • Forum Assistance
      • New Cruisers
      • Cruise Lines “A – O”
      • Cruise Lines “P – Z”
      • River Cruising
      • ROLL CALLS
      • Digital Photography & Cruise Technology
      • Member Cruise Reviews
      • Special Interest Cruising
      • Cruise Discussion Topics
      • UK Cruising
      • Australia & New Zealand Cruisers
      • North American Homeports
      • Ports of Call
      • Cruise Conversations
×
×
  • Create New...